Drupal7集成Solr5.5与IK Analyzer中文分词

归类于Drupal | 服务器技术 参与评论

虽然Solr6已经发布了,但是drupal还没有任何相关的模块支持,不过Solr5.x已经可以用到drupal上了。 本文把延续之前的Drupal和IK的配置,升级到一键安装包solr5.5,支持中文分词,支持Drupal7,如果需要新建core,可以把默认的drupal7/conf复制到新建的core下面的conf文件夹即可。

solr5.5配置IK中文分词

  阅读全文 《Drupal7集成Solr5.5与IK Analyzer中文分词》

554 Views , ,

Drupal 7整合Apache Solr 4.7及中文分词

归类于其他 一条评论

solr的版本升级较快,目前已经到5.x的版本,但是drupal的版本升级比较慢,因此关于drupal升级使用solr高版本的问题,进展也比较慢,另外一个原因是Drupal的apachesolr模块是否支持也是一个问题,所以作者建议不要盲目的升级使用高版本,一定要测试之后才能在正式服务器上使用。

阅读全文 《Drupal 7整合Apache Solr 4.7及中文分词》

994 Views , , ,

Apache Solr 快速启动包以及中文分词集成

归类于Drupal | 数据库技术 | 服务器技术 2 条评论

Solr一键启动包,Apache Solr中文支持包。

apachesolr 作为一款全文搜索引擎大家都很了解,不过说到中文的支持,(4.0版本之前),总是不能让人满意。首先,我们感谢一下IKAnalyzer的作者,开发了Lucene的中文分词包。
阅读全文 《Apache Solr 快速启动包以及中文分词集成》

3,913 Views , , , ,

Drupal集成ApacheSolr-3.x以及中文分词处理

归类于服务器技术 5 条评论

本文主要讲解drupal和Apache solr-3.x的集成以及对中文分词的处理,如需详细了解Drupal Search以及Apache Solr的工作原理,请参阅前文《Drupal北京聚会主题之 – Apache Solr》。

在默认情况下,Drupal6使用的是Apache Solr 1.4版本,但是Apache Solr新版本已经升级到了3.x,所以1.x版本可能会慢慢不再支持,所以升级到Apache Solr 3.x还是很有必要的,我们这里做一下简要的介绍以及在Drupal Apachesolr中如何处理中文分词的相关问题。

升级到apachesolr 3.x

由于版本的兼容问题,我们选择第一个3.x版本,Apache Solr-3.1.0作为Apache Solr的主版本,来与Drupal6一起测试。首先要安装Drupal的Apachesolr模块,具体的安装操作在Drupal Apchesolr模块的README.txt里面有详细说明,在这只大概列举一下。

  1. 下载apachesolr模块
  2. 下载SolrPhpClient包,具体参考apacheslor README文件
  3. 从Apache网站下载solr包
  4. 把drupal apachesolr中的schema.xml和solrconfig.xml拷贝到solr的example/solr/conf/下(注意备份源文件)
  5. 到solr的example下,java -jar start.jar 启动SOLR

阅读全文 《Drupal集成ApacheSolr-3.x以及中文分词处理》

4,501 Views , , , ,

顶部