Drupal6 如何升级到 jQuery1.7

归类于Drupal 参与评论

在Drupal6中默认的jQuery版本比较低,但是即使通过jquery_update模块升级jQuery也只能将其升级到jQuery1.3.2,由于该版本相对jQuery最新版本仍然较老,因此很多插件无法使用,新的jQuery特效无法兼容,给开发Drupal6项目开发带来很多不便。

由于Drupal的jQuery升级不仅仅只是替换jQuery.js文件这么简单,并且包括相关第三方模块对新版本的jQuery兼容问题,因此我们自行升级jQuery是比较困难的。笔者此前在网上见到过同时使用两个版本的jQuery,也算是一种解决方案,不过此方案确实算是不得已而为之的办法罢了,两套jQuery维护以及用户加载都不方便。

  Continue reading “Drupal6 如何升级到 jQuery1.7” »

328 Views ,

顶部